Hyper Olympic Konami PCB repair [25.12.2019]

das war ein echt harter brocken, dachte schon ich gebe auf, aber das tut man ja bekanntlich nur einen brief.

also was waren die fehler:

  1. platine bootet mal gar nicht
  2. dafür aber humming sound am lautsprecher

der LS139 auf 9D hatte komplett den geist aufgegeben. eigentlich auf gut glück draufgekommen da der ziemlich dunkelschwarz war und somit ein kandidat für eine „Ab-rauchung“. gemessen, nix. also ausgelötet und neuen rein. hmm jetzt tut sich zumindest ein wenig was am adress-/datenbus. noch einen verdächtigen gefunden. 14D LS139 gemessen, ausgelötet, fehlerhaft, neuen rein, tada sie bootet. aber ziemlich schlechte sprites – das deutet auf einen defekten ram oder ähnliches hin. in meinem fall aber auf die custom-platine

rechts oben die platine musste nachgelötet werden. kalte lötstelle

alles klar, jetzt zum nächsten problem, nur humming sound aus dem lautsprecher. das gestaltete sich noch schwieriger als das 1. problem

amp war ok sonst wäre ja gar nix zu hören.

eproms ausgelesen,

beide eproms keine lebenszeichen, ausgelesen, nix. daher gleich mal neu gebrannt. keine veränderung

der LS374 auf 8C machte auch faxen bei den ausgängen daher auch ausgelötet. keine veränderung. der custom A1 manchmal beim einschalten (aber nicht immer) keine aktivität auf dem datenbus), dachte schon der ist faul, aber mal weitergesucht. Die 8B 76489AN macht auch nix auf PIN7 SND OUT – an dem hatte ich noch keine erfahrung. was tun??? gott sei dank hatte ich noch ein hyper olympic bootleg mit dem selben chip welches einwandfrei läuft. gleich mal an pin7 gemessen, hmm, genau gleich also mal als ok tituliert. ram mit piggy-pack methode (2D und 3D versucht, hmm humming ist weg aber keine musik und keine geräusche), ein neuer verdacht also. einen ausgelötet auf 3D. gleich mal trace abgerissen, na ja egal kann man ja neu legen. gesagt getan, neuen 2114er rein. juhu, ton und geräusche da. läuft wieder einwandfrei.

einer meiner härtesten gegner im pcb-reparaturbuch bisher. fürchte aber es kommen noch schwierigere.

na ja die batterie wurde natürlich auch ersetzt da keine highscores gespeichert wurden. 0,7v ist doch etwas zu wenig. die gehört noch eingelötet (aber kein ersatz momentan daheim).

Materialeinsatz ziemlich hoch gott sei dank keine cpu´s oder customs.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.