Galaxian Namco repair [26.07.2020]

von Alex wieder mal was zum reppen bekommen. diesmal 2 stück galaxian (1x namco, 1x bootleg).

zuerst die von namco, diagnose: kein bild kein nichts na das kann ja heiter werden.

mit folgendem komischen daughterboard welches ich so noch nicht kannte. aber dazu später mehr (bzw. weniger)

wie sich herausstellte passte das board so gar nicht auf die hauptplatine also runter damit, was auch immer ein vorgänger damit wollte, ich weiß es nicht und es ist mir auch schnuppe denn der auftrag war „mach das galaxian wieder lauffähig“ und das hatte ich auch vor.

nach kurzer testerei wurde mir sofort klar dass der watchdog zuschlägt. also iwo am board ein blöder fehler. namco hat einen mechanismus wo man das übergehen kann (jumper) also versucht. nix.

z80 cpu getauscht und wir haben ein bild (also cpu defekt). aber kein bewegtes nur garbage.

es gibt für galaxian einen 2rom hack den hab ich gleich mal versucht: http://www.paladingrp.com/brianb/board_hacks/galaxian/

das ganze sieht dann ungefähr so aus. ist am link genau nachzulesen, damit halte ich mich jetzt nicht auf.

aha wir haben eine laufende cpu aaaaaber. ram error 1 hmmm schit, also mal die beiden rams auf 7p und 7n mit piggy-pack methode versucht. nichts immer noch ram fehler. ausgelötet, neu gesockelt, immer noch ram fehler. da ich die rams leider ohne fluke nicht onboard testen kann (iwann kauf ich mir noch so ne fluke ;-)) bleibt mir nichts anderes übrig als auszulöten und neue rein. hmm immer noch selber fehler. durch zufall kam ich dann drauf dass das rom in 7L (schlichtweg blöde sockel auf den namco boards) nicht gut gesteckt war, etwas zusammen (ja zusammen) biegen hat geholfen und wir haben ein bild und ein funktionierendes galaxian.

bis auf den ton. hier waren dann noch der LS161 und der LS259 im soundbereich defekt. es waren beim explodieren der gegner keine töne zu hören. ach ja ein trace vom ram war auch noch vom vorgänger mehr schlecht als recht repariert worden. da kam mir mein isolationsdraht wieder mal zu hilfe

alles in allem ein paar stunden arbeit ein paar elkos (welche ich auch noch getauscht habe) ein paar ics und rams und dat ding läuft wieder.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.