Chase HQ PCB repair [update 20.11.2018]

[update historie — 06.11.2018 — 20.11.2018]

ein neuer patient auf dem tisch.

IMG_20181107_074843IMG_20181107_074838

erstmal videoadapter löten, damit ich überhaupt bild sehen kann. der rest ist jamma-ähnlich aber auch nicht wirklich, für meine reparatur reicht es aber aus.

IMG_20181107_074900

so mal einschalten, ziemlich hungriges teil die pcb. komme auf max. 5,87amp bei 4,63V. ich glaube ich muss echt mal ein größeres netzteil kaufen. wenn das nicht alles soooo teuer wäre.

eine chase hq baustelle mit folgendem phänomen: striche quer durch die sprites:

IMG_20181106_143637img_20181106_143628.jpg

zuerst hatte ich die rams in verdacht, da ich keine vorrätig hatte, wurden vom daniel, dem gehört die pcb, welche bestellt. mit der piggy-back methode brachte das allerdings keine veränderungen, somit an die eproms und siehe da:

IMG_20181106_190551IMG_20181106_190557

zuerst versuchte ich es mit meinem galep 4 auszulesen, das ging auch, brachte auf romident aber kein ergebnis, na ja dachte ich mal mit dem tl866 auslesen vielleicht liefert der ja was brauchbares, und siehe da beim einlesen gleich mal ein pin fehler. meine hoffnung liegt jetzt darin dass durch ein neues eprom (muss ich natürlich auch wieder erst bestellen *grml*) das ganze wieder zum laufen gebracht werden kann. Daniel würde sich bestimmt freuen. übrigens es handelt sich um ic5 auf dem videoboard.

inzwischen stellte sich heraus dass noch weitere defekte an dem board sind, die ich aber gleich mal behoben habe (isolierdraht funktioniert hier echt super). da dürfte mal zuviel strom drübergelaufen sein.

IMG_20181107_074851

hoffentlich finden sich nicht noch mehr solche broken traces. taito ist ja bekannt dafür dass die traces wegkorrodieren wie die schmeißfliegen. aber die hoffnung stirbt ja bekanntlich zuletzt. ich setze momentan alles auf das defekte eprom.

 

[update 20.11.2018]

das eprom wurde geliefert, beschrieben und getestet. spiel läuft wieder einfwandfrei und ist auch schon zurück bei seinem besitzer.

One Comment

  1. René

    Cool.. habe auch ein Board über eBay erworben. Allerdings defekt.. mit 12 V ist der tc0020DAC durchgeglüht.. warum auch immer.. sehe keinen Kurzschluss.. und der tc0070 rgb ist vom Board abgebrochen..

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.