Ghosts n Goblins bootleg repair [29.05.2019]

das teil brachte mich echt fast um den Verstand, aber von vorne.

auf willhaben gekauft, verkäufer meinte es sei eine wonderboy. da dachte ich oha, die kauf ich mir. preis stimmte auch. er meinte sie funktioniere, aber er kann keine fotos machen… jaja, somit mal von einer defekten pcb ausgegangen, aber na ja sei´s drum.

lieferung in 2 tagen, (wenn´s wirklich wichtig ist dann lieber mit der post *G*) ausgepackt uuuuunnnnnnndddd …….nie im leben eine wonderboy, das ist eine ghosts n goblins bootleg. freu.

IMG_20190529_090309

 

also capcom adapter dran und check. verdammt, white screen, das ding bootet nicht.

die gängigen verdächtigen, eproms, rams, clock usw. gecheckt.

eproms 2 von 3 maincpu roms tot. neu gebrannt. (GNGC.zip), achtung die GNGBLITA.zip funktionieren an der pcb nicht, dazu aber später mehr.

eingebaut, funktioniert nicht, selbes fehlverhalten. na ja was checkt man dann? clocksignal.

IMG_20190524_142013

gar nix zum messen. lediglich die 50hz brummschwelle. könnte der quarz sein oder was in der nähe.

quarz sieht übel aus:

IMG_20190524_142053

frage im AZ, der gute Winni meint die dinger gehen nicht kaputt. zu spät, hatte schon welche bestellt. wird lagerware, denn der quarz ist ok. LS04 auf 3N ausgelötet und neuen versucht, nix. warum wohl? die vergammelte pcb hatte korrosion und die hatte einen trace abgefressen. also neu geflickt und ….. clocksignal liegt am mc6809 super an:

schönes rechtecksignal wie es sich gehört. 6mhz

adress und datenleitungen tot. mrdy und irq low, hmmmm mal die cpu ausgelötet und neu. sieht schon besser aus. manchmal garbarge am screen und dann sofort wieder weißer schirm. weiter zu cpu ram. hmm komisches verhalten, piggypackmethode keine verbesserung, hab ihn ausgelötet und neuen gesockelt, nix, keine verbesserung. ab in die foren und repair logs gelesen. die 245er bustreiber gehen gerne kaputt. dir und enable signale ok, aber fujitsu ttls sterben mitunter komischen anzeigesignalen. also raus damit und neue gesockelt. danach die komplette mrdy schiene rückverfolgt da hier nur ein pulsen zu messen war. eigentlich sollte die stabil high bleiben (analog zum irq)

tada, das teil läuft wieder. irgendwie dürften sich die adressen da an den ls245ern gestört haben. übrigens es waren die beiden auf 10H und 11H.

zu den eproms gilt noch zu sagen, viel zeit habe ich mit den gngblita proms vergeudet. die hätte ich zuerst versucht aber passten nicht zu dem board. des rätsels lösung nach einer wahren entlöt/löt-orgie waren dann die gngbc.zip eproms für die main-cpu.

IMG_20190529_145848

 

für ne Ghosts n Goblins mach ich das gerne auch wenn bootleg.

 

viel gelernt, viel halbleiterware verbraucht aber im endeffekt hat es sich gelohnt.

 

repair log ende.

 

 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.