another Bomb-Jack PCB repair [02.10.2019 — 04.10.2019 — 05.10.2019 –06.10.2019]

[02.10.2019]

wieder eine Bomb-Jack PCB zum reppen. die hab ich geschenkt bekommen, komplett tot.

reset line pulst wie wild. mal die schematics zu rate gezogen.

clock signal perfekt 4mhz am z80 da ist also kein fehler. weiter zurückverfolgt.

5N Pin 8 gibt das reset signal aus. das pulst auch also weiter zurück

WD Clear 12/13 passt nicht aber auch vblank passt nicht. zurück auf einen LS74 (fujitsu) auf 7P. da passt was nicht. also raus:

neuen eingelötet (gesockelt natürlich). program läuft, aber noch einige Farbfehler.

Ton läuft auch nicht. hier war die Z80 und die audioamp defekt. jetzt zwar etwas ton aber noch nicht richtig. weitersuchen ist also angesagt.

[update 04.10.2019]

habe mich jetzt 2 tage mit folgendem Problem beschäftigt:

kein Hintergrundbild und farben rollen immer von rot nach blau via grün (oder ähnlich).

Hintergrundbild war ein defekter LS157 auf 6D am Videoboard

das mit den rollenden Farben war noch etwas komplizierter:

ein LS174 auf 5S war komplett auf jedem pin auf high. der hat wohl mal einen schuss bekommen:

danach war das Bild wieder komplett in ordnung (Hintergrund + Rollende Farben).

jetzt noch der sound, da fehlt die hintergrundmusik komplett. töne kommen aber raus. hab die 51516 audioamp schon getauscht aber da fehlt noch ein wenig hirnschmalz hineinstecken. sobald das aber ok ist kommt sie ins regal bzw. trenn ich mich wieder von ihr.

[update 05.10.2019]

hab heute noch etwas verschönerung und etwas für die stabilität gemacht aber seht selbst:

Fertig montierte PCB
Videostecker
Audio Amp Kühler
Plastikschrauben fixierung
Adapter
5V und 12V LED

platine gut fixiert mit 6 schrauben und füßchen, den videostecker erneuert (steckbar), audio-amp mit kühlblech versehen und die 5v und 12v LED überwachung aktiviert :-), ein adapter darf natürlich auch nicht fehlen

ganz schön viel Müll was da ersetzt werden musste

[update 06.10.2019]

Endlich ein Durchbruch beim Sound. 2 der 3 AY-3-8910 (3B und 3C) waren defekt (auf IO 17 18 19 keine Aktivität). die dürften wohl auch opfer einer Überspannung gewesen sein. die Elkos auf C1-C9 (ursprünglich 10mü 16v) habe ich durch 10mü 6,3V ersetzt, da geht max 2,35V drüber die sollten einige zeit durchhalten.

80 pins aus und einlöten ist ne blöde arbeit, aber danach:

Endlich ist die komplette Reparatur abgeschlossen. manche fragen sich wohl jetzt warum das ganze für ein bootleg, aber ich muss sagen, bombjack ist ein klassiker und dieses ist ganz gut verarbeitet und außerdem hab ich jede menge über diese PCB gelernt. vielleicht (und ich bin mir fast sicher) landet ja wieder mal ein kandidat auf meiner reparatur-bank

closed.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.