Galaga Repair Log [update 19.11.2019]

ein klassiker und dazu noch original, der gehört auf jeden fall repariert. leider hat sich mein vorgänger an der platine so richtig ausgetobt sodass ich lange suchen musste um alle fehler beheben zu können. etwas glück war dann auch noch dabei.

aber zuerst mal von vorne an:

platine bootet nicht und bringt nur garbage, keine bewegung daher cpu tot war die vermutung. hmm da hat schon mal wer rumgebastelt und einen präzisionssockel eingelötet. leider sind diese sockets meiner meinung nach nur schrott und für den arcade bereich nicht verwendbar. und tatsächlich waren 2 traces unterbrochen. dies dürfte beim auslöten passiert sein.

na die mal geflickt und wir haben bewegung am bildschirm. nächstes problem war ein defekter ram (2016 auf dem videoboard)

und auch die schrottigen widerstandsarrays habe ich gleich mal ausgelötet und durch neue ersetzt. in diesem fall 2,2k. hier waren bei den alten keramik-arrays 2 pins abgelöst.

so jetzt waren auch noch 4 2016er rams am videoboard im eimer. also nach der reihe getauscht und das bild bleibt bei RAM OK stehen, außerdem stimmt die farbe noch nicht

also mal die eproms gecheckt. davon waren auch gleich mal mehrere physisch defekt und bei 2en passte die version nicht. ich habe ein midway1981 board daher auch die midway original roms gebrannt.

leider keine verbesserung, also mal alle custom chips raus und gecheckt. aha jede menge beinchen abgebrochen (altersbedingt), das ist eine extreme schwachstelle bei den boards (nach den elendigen eprom sockeln, die gehören alle getauscht…) und natürlich auch hier wieder vom vorgänger ein trace abgerissen. den habe ich geflickt damit man es aber gleich sieht nicht unterm sockel sondern am custom druff. rechts daneben das geflickte beinchen.

aha und wir kommen der sache schon näher. jetzt bootet sie!!!

sogar fehlerfrei, alle sounds sind da und man kann spielen. noch zu erwähnen sei dass ich jede menge custombeinchen repariert habe, geputzt, neu gesockelt usw. war viel arbeit, lohnt sich aber für den kollegen.

achja, ganz vergessen, 2x ls367 am cpu board habe ich auch noch getauscht. natürlich auch wieder gesockelt.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.